ODBC 経由で PowerBuilder から Accelo のデータ に接続

Jerod Johnson
Jerod Johnson
Director, Technology Evangelism
CData ODBC Driver for Accelo を使用して PowerBuilder からAccelo のデータに接続し、クエリを実行する方法を説明します。



CData ODBC Driver for Accelo は、ODBC をサポートするあらゆるプラットフォームや開発技術から使用できます。PowerBuilder もその一つです。この記事では、Accelo のデータ に接続し、Database Painter や DataWindow などのコントロールからクエリを実行する方法を説明します。

Accelo にODBC データソースとして接続

まだ設定していない場合は、ODBC DSN(データソース名)で接続プロパティを指定します。これはドライバーインストールの最後のステップです。Microsoft ODBC データソースアドミニストレーターを使用して、ODBC DSN を作成・設定できます。

まず、Profile 接続プロパティをディスク上の Accelo プロファイルの場所に設定します(例:C:\profiles\Accelo.apip)。次に、ProfileSettings 接続プロパティを Accelo の接続文字列に設定します(以下を参照)。

Accelo API プロファイル設定

Accelo で「Configuration > API > Register Application」から OAuth アプリケーションを登録します。クライアント ID、クライアントシークレット、リダイレクト URI は、アプリの設定画面で確認できます。

Accelo 用 ODBC ドライバ のプロファイルを作成

以下の手順に従って、Database Painter ツールを使用し、Accelo の ODBC DSN(データソース名)に基づいてデータベースプロファイルを作成します。Database Painter では、ウィザードや UI を使用してAccelo のデータを操作できます。

  1. PowerBuilder で、[ツール] -> [Database Painter]をクリックします。
  2. Database Painter の [オブジェクト] ウィンドウで、ODBC ノードを右クリックし、[新しいプロファイル] をクリックします。
  3. [接続] タブで、プロファイル名を入力し、[データソース] メニューで Accelo DSN を選択します。 データベースプロファイル作成に必要な ODBC DSN(Salesforce の例)
  4. テーブルを表示・編集するには、テーブルを右クリックして [データの編集] -> [グリッド] をクリックします。
編集可能なグリッドからアクセスできるライブデータ(Salesforce の例)

PowerBuilder コントロールで Accelo のデータ を使用

標準の PowerBuilder オブジェクトを使用して ODBC データソースに接続し、クエリを実行できます。以下の例では、Accelo のデータ を DataWindow に取得する方法を示します。次のコードを open メソッドに追加してください。


SQLCA.DBMS = "ODBC"
SQLCA.DBParm = "ConnectString='DSN=CData API Source'"
CONNECT USING SQLCA;
dw_activities.SetTransObject(SQLCA);
dw_activities.Retrieve();

はじめる準備はできましたか?

API Driver で Accelo のライブデータに接続

Accelo に接続