WCF でApache Airflow の OData サービスを公開する方法
CData ADO.NET Provider for Apache Airflow を使用すると、Windows Communication Foundation(WCF)フレームワークを活用してサービス指向アプリケーションを素早く開発し、Apache Airflow のデータを OData コンシューマーに提供できます。この記事では、接続用の Entity Data Model を作成し、WCF Data Service を構成して OData サービスを公開する方法を解説します。公開したフィードは、Power Pivot や CData ADO.NET Provider for OData を使用するアプリケーションなど、さまざまな OData クライアントから利用できます。
OData サービスの作成
以下の手順で、OData 経由でApache Airflow のデータへの接続を提供する WCF サービスアプリケーションを作成します。
- Visual Studio を開き、新しいプロジェクトを作成します。WCF Service Application テンプレートを選択します。
- 自動生成された IService.cs と Service1.svc を削除します。
- Entity Framework 6 をインストールします:
Visual Studio のパッケージマネージャーコンソールを使用して、最新バージョンの Entity Framework をインストールします。以下のコマンドを実行すると、Entity Framework が自動的にダウンロード・インストールされます。
Install-Package EntityFramework - Entity Framework プロバイダーを登録します:
- App.config または Web.config ファイルの "providers" セクションに、以下のプロバイダーエントリを追加します。Entity Framework のインストールが成功していれば、このセクションはすでに存在しているはずです。
<configuration> ... <entityFramework> <providers> ... <provider invariantName="System.Data.CData.API" type="System.Data.CData.API.APIProviderServices, System.Data.CData.API.Entities.EF6" /> </providers> </entityFramework> </configuration> - インストールディレクトリの lib/4.0 にある System.Data.CData.API.Entities.dll への参照を追加します。
- プロジェクトをビルドして、EF6 のセットアップを完了します。
- App.config または Web.config ファイルの "providers" セクションに、以下のプロバイダーエントリを追加します。Entity Framework のインストールが成功していれば、このセクションはすでに存在しているはずです。
- Project -> Add New Item -> ADO.NET Entity Data Model をクリックします。
- 表示される Entity Data Model ウィザードで、'EF Designer from Database' オプションを選択します。
- Choose Your Connection ダイアログが表示されたら、New Connection をクリックします。
Connection properties ダイアログで、CData Apache Airflow Data Source を選択し、必要な認証情報を入力します。
一般的な接続文字列は以下のとおりです:
Profile=C:\profiles\ApacheAirflow.apip;AuthScheme=APIKey;ProfileSettings='APIKey=your_jwt_token;Server=http://localhost:8080';まず、Profile 接続プロパティをディスク上の ApacheAirflow プロファイルの場所に設定します(例:C:\profiles\ApacheAirflow.apip)。次に、ProfileSettings 接続プロパティを ApacheAirflow の接続文字列に設定します(以下を参照)。
ApacheAirflow API プロファイル設定
Apache Airflow 3 では、API 認証に JWT Bearer トークンを使用します。トークンは、Airflow Web UI の「Settings」から生成するか、Airflow CLI の airflow users create と /api/v2/auth/token エンドポイントを使って生成できます。なお、このプロファイルは /api/v2 REST API を使用する Apache Airflow 3.x を対象としています。Airflow 2.x で使われていた従来の /api/v1 エンドポイントには対応していません。
以下の接続プロパティを設定すると、接続できるようになります。
- AuthScheme:APIKey に設定します。
- APIKey:Apache Airflow の JWT Bearer トークンに設定します。
- Server:Airflow インスタンスのベース URL に設定します(例:http://localhost:8080)。

- OData クライアントからアクセスさせたい Apache Airflow のテーブルとビューを選択します。

- Project -> Add New Item -> WCF Data Service をクリックします。
データソースクラスを指定し、新しい WCF Data Service へのアクセスを構成します。以下の例では、エンティティの Access Rule が All に設定されています。これは、すべてのユーザーがデータの読み取りと変更を行えることを意味します。
able to read and modify data.using System; using System.Collections.Generic; using System.Data.Services; using System.Data.Services.Common; using System.Linq; using System.ServiceModel.Web; using System.Web; namespace APIService{ public class APIDataService : DataService<APIEntities> { public static void InitializeService(DataServiceConfiguration config) { config.SetEntitySetAccessRule("*", EntitySetRights.All); config.DataServiceBehavior.MaxProtocolVersion = DataServiceProtocolVersion.V3; } } }-
プロジェクトを実行します。これで、OData 対応アプリケーションから Salesforce データにアクセスし、変更を反映できるようになります。ブラウザでフィードにアクセスできます。フィードは次のように表示されます:
Power Pivot から OData サービスを利用する
これで、任意の OData クライアント(例:Excel Power Pivot)からサービスを利用できます。
- Excel を開き、Power Pivot Window ボタンをクリックします。
- 新しいポップアップが表示されます。From Data Feeds オプションを選択します。
- 表示される Table Import Wizard で、OData URL を入力します(例:http://localhost:12449/APIDataService.svc/)。
- OData サービスへの接続後、ウィンドウ下部の Next ボタンをクリックします。
- ウィザードの次のウィンドウに、利用可能なテーブルの一覧が表示されます。インポートするテーブルを選択し、Finish をクリックします。
- Close をクリックして、Power Pivot にデータをインポートします。