ODBC 経由で PowerBuilder から Deepgram のデータ に接続
CData ODBC Driver for Deepgram は、ODBC をサポートするあらゆるプラットフォームや開発技術から使用できます。PowerBuilder もその一つです。この記事では、Deepgram のデータ に接続し、Database Painter や DataWindow などのコントロールからクエリを実行する方法を説明します。
Deepgram にODBC データソースとして接続
まだ設定していない場合は、ODBC DSN(データソース名)で接続プロパティを指定します。これはドライバーインストールの最後のステップです。Microsoft ODBC データソースアドミニストレーターを使用して、ODBC DSN を作成・設定できます。
まず、Profile 接続プロパティをディスク上の Deepgram プロファイルの場所に設定します(例:C:\profiles\Deepgram.apip)。次に、ProfileSettings 接続プロパティを Deepgram の接続文字列に設定します(以下を参照)。
Deepgram API プロファイル設定
Deepgram では、すべてのエンドポイントで API キー認証を使用します。API キーはプロジェクト単位で発行され、権限スコープ(member、administrator、owner)が付与されます。API キーは Deepgram コンソールで作成・管理できます。
API キーを取得したら、以下の接続プロパティを設定します。
- AuthScheme:APIKey に設定します。
- APIKey:Deepgram の API キーに設定します。
Deepgram 用 ODBC ドライバ のプロファイルを作成
以下の手順に従って、Database Painter ツールを使用し、Deepgram の ODBC DSN(データソース名)に基づいてデータベースプロファイルを作成します。Database Painter では、ウィザードや UI を使用してDeepgram のデータを操作できます。
- PowerBuilder で、[ツール] -> [Database Painter]をクリックします。
- Database Painter の [オブジェクト] ウィンドウで、ODBC ノードを右クリックし、[新しいプロファイル] をクリックします。
- [接続] タブで、プロファイル名を入力し、[データソース] メニューで Deepgram DSN を選択します。
- テーブルを表示・編集するには、テーブルを右クリックして [データの編集] -> [グリッド] をクリックします。
PowerBuilder コントロールで Deepgram のデータ を使用
標準の PowerBuilder オブジェクトを使用して ODBC データソースに接続し、クエリを実行できます。以下の例では、Deepgram のデータ を DataWindow に取得する方法を示します。次のコードを open メソッドに追加してください。
SQLCA.DBMS = "ODBC"
SQLCA.DBParm = "ConnectString='DSN=CData API Source'"
CONNECT USING SQLCA;
dw_keys.SetTransObject(SQLCA);
dw_keys.Retrieve();