Power View でのLinear のデータのインポートとビジュアライズ

古川えりか
古川えりか
コンテンツスペシャリスト
Excel でLinear のデータを使ったデータビジュアライゼーションを作成します。



Excel に組み込まれているODBC サポートを使用して、Linear のデータを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、Linear をPower View レポートにインポートする方法を説明します。

CData ODBC ドライバとは?

CData ODBC ドライバは、以下のような特徴を持ったリアルタイムデータ連携ソリューションです。

  1. Linear をはじめとする、CRM、MA、会計ツールなど多様なカテゴリの270種類以上のSaaS / オンプレミスデータソースに対応
  2. 多様なアプリケーション、ツールにLinear のデータを連携
  3. ノーコードでの手軽な接続設定
  4. 標準 SQL での柔軟なデータ読み込み・書き込み

CData ODBC ドライバでは、1.データソースとしてLinear の接続を設定、2.Power View 側でODBC Driver との接続を設定、という2つのステップだけでデータソースに接続できます。以下に具体的な設定手順を説明します。

CData ODBC ドライバのインストールとLinear への接続設定

まずは、本記事右側のサイドバーからLinear ODBC Driver の無償トライアルをダウンロード・インストールしてください。30日間無償で、製品版の全機能が使用できます。

未指定の場合は、初めにODBC DSN で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。

Linear への認証には、個人用 API キーまたは OAuth 2.0 を使用できます。ご自身の Linear アカウントで接続する場合は、API キーを使うのが最も手軽です。

API キーによる認証

以下の接続プロパティを設定します。

  • AuthScheme:APIKey に設定します。
  • APIKey:Linear の個人用 API キー。

個人用 API キーを作成するには、Linear にログインして Settings > Security & access > Personal API keys を開き、New API key を選択して作成します。キーは一度しか表示されないため、すぐにコピーしておきましょう。

OAuth による認証

OAuth を使用するには、Linear にカスタム OAuth アプリケーションを登録する必要があります(Settings > API > OAuth applications)。登録すると OAuthClientId と OAuthClientSecret が発行されます。対応しているフローは以下の 2 つです。

  • Authorization code:AuthScheme を OAuth、InitiateOAuth を GETANDREFRESH に設定し、OAuthClientId、OAuthClientSecret、およびアプリケーションで定義した CallbackURL(例:http://localhost:33333)を指定します。ドライバーがブラウザで Linear を開くので、アクセスを許可してください。
  • Client credentials:AuthScheme を OAuthClient に設定し、OAuthClientId と OAuthClientSecret を指定します。アプリケーション自体を認証するためブラウザ操作は不要で、マシン間(M2M)連携に適しています。

デフォルトでは、ドライバーは read,write スコープをリクエストします。アクセストークンは有効期限が切れると自動で更新されます。

DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。

Data Connection Wizard で接続

以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。

  1. [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
  2. [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
  3. リストから[ODBC DSN for Linear]を選択します。
  4. 操作するテーブルを選択します。

    複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。

  5. [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
  6. [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。

テーブルの作成

テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。

A table with a filter applied.(Salesforce is shown.)

データのビジュアライゼーションを作成

[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。

The table of data represented as a stacked bar chart.(Salesforce is shown.)

Linear からPower View へのデータ連携には、ぜひCData ODBC ドライバをご利用ください

このようにCData ODBC ドライバと併用することで、270を超えるSaaS、NoSQL データをコーディングなしで扱うことができます。30日の無償評価版が利用できますので、ぜひ自社で使っているクラウドサービスやNoSQL と合わせて活用してみてください。

CData ODBC ドライバは日本のユーザー向けに、UI の日本語化、ドキュメントの日本語化、日本語でのテクニカルサポートを提供しています。

はじめる準備はできましたか?

Linear ODBC Driver の無料トライアルをダウンロードしてお試しください:

 ダウンロード

詳細:

Linear Icon Linear ODBC Driver

Linear ODBC Driver は、ODBC 接続をサポートするさまざまなアプリケーションからLinear のリアルタイムデータ連携を実現するパワフルなツールです。

データベースにアクセスするときと同感覚でLinear データにアクセスし、標準ODBC Driver インターフェースを通じてLinear データを読み出せます。