Lazarus Pascal IDE で Sage X3 Cloud のデータを簡単に統合

Mohsin Turki
Mohsin Turki
Technical Marketing Engineer
CData ODBC Driver を使用して Lazarus Pascal IDE でSage X3 Cloudのリアルタイムデータを簡単に統合する方法を紹介します。

Lazarus Pascal IDE は、クロスプラットフォームアプリケーションを構築するための強力で無料のオープンソース開発環境です。CData ODBC Driver for Sage X3 Cloud を使用すれば、Sage X3 Cloud のデータ をシームレスに統合してクエリを実行でき、Lazarus Pascal IDE アプリケーション内でリアルタイムのインサイトを活用して、レポート、ダッシュボード、ワークフローを強化できます。

本記事では、接続のセットアップから Lazarus Pascal IDE でリアルタイムの Sage X3 Cloud データを活用するまでの包括的な手順をご紹介します。レポート、ダッシュボード、複雑なワークフローを構築する際に、アプリケーション内でリアルタイムのインサイトと機能を実現するためのツールを習得できます。

概要

本記事の手順の概要は以下のとおりです。

  1. CData ODBC Driver for Sage X3 Cloud で Sage X3 Cloud のデータ 用の DSN を必要な接続プロパティで設定します。
  2. Lazarus で ODBC 接続をセットアップします。TSQLConnector、TSQLQuery、TDataSource、TDBGrid コンポーネントを必要な情報で設定します。
  3. Main フォームにサンプルコードを記述して、Sage X3 Cloud のデータ への接続をテストします。
  4. アプリケーションをコンパイルして実行し、Sage X3 Cloud のデータ の統合と表示が正常に行われることを確認します。

前提条件

開始する前に、以下の準備が必要です。

  • Lazarus IDE(バージョン 3.4 推奨)。こちらからダウンロードできます。
  • CData ODBC Driver for Sage X3 Cloud。最新版をこちらからダウンロードしてお試しください。


CData ODBC Driver で Sage X3 Cloud DSN を設定

まず、CData ODBC Driver for Sage X3 Cloud を使用してシステムでSage X3 Cloud のデータ用の DSN(データソース名)を設定します。こちらから全機能を備えた 30日間の無償トライアルをダウンロードしてインストールしてください。

インストールが完了したら、ODBC データソースアドミニストレーターを起動します。

  • Windows の場合:スタートメニューで ODBC データソースアドミニストレーター を検索してアプリケーションを開きます。
  • Mac の場合:アプリケーションを開き、ユーティリティに移動して ODBC Manager を選択します。
  • Linux の場合:コマンドラインを使用して ODBC データソースアドミニストレーター を起動するか、インストールされている場合は unixODBC を使用します。
ODBC データソースアドミニストレーターダイアログ(Salesforce の例)

起動したら、CDataSage X3 Cloud のデータSource をダブルクリックして、接続を確立するために必要な値を入力します。

Sage X3 Cloud では OAuth 2.0 の Client Credentials フローを使用し、API へのアクセスには X-API-Key も必要です。AuthScheme を OAuth に設定し、以下の接続プロパティを指定します。

  • URL:Sage X3 Cloud インスタンスのベース URL。
  • OAuthAccessTokenUrl:OAuth トークンエンドポイント(例:https://your-auth-domain/oauth/token)。
  • OAuthClientId:OAuth アプリケーションのクライアント ID。
  • OAuthClientSecret:OAuth アプリケーションのクライアントシークレット。
  • Audience:トークンリクエストで使用する API の Audience 値。
  • XAPIKey:Sage X3 Cloud の管理者から提供された X-API-Key。
  • Folder:Sage X3 のフォルダ名(例:SEED)。このフォルダがデフォルトのスキーマとして使用されます。
  • Folders(オプション):Sage X3 フォルダのカンマ区切りリスト(例:SEED,PERF)。各フォルダが個別のスキーマとして公開されるため、Schema.Table 構文でフォルダをまたいだクエリを実行できます。

ドライバーは Client Credentials フローでアクセストークンを取得し、すべての API リクエストで X-API-Key とあわせて送信します。InitiateOAuth を GETANDREFRESH(デフォルト)に設定しておけば、トークンの取得と更新は自動で行われます。

CData ODBC Driver for Salesforce - DSN 設定ダイアログ

新しい GUI プロジェクトを作成

  1. Lazarus IDE を起動します。
  2. File > New > Application に移動して、Main フォームを持つ新しい GUI プロジェクトを作成します。
Lazarus で新しい GUI プロジェクトを作成

フォームに必要な接続コンポーネントを追加

  1. View > Component > Palette に移動し、左下の Keep open にチェックを入れて、コンポーネントウィンドウを常に開いた状態に保ちます。
  2. 以下のコンポーネントを検索し、右下の Use をクリックして Main フォーム Form1 に追加します。
    1. TSQLConnector
    2. TSQLTransaction
    3. TSQLQuery
    4. TDataSource
    5. TDBGrid
Lazarus Pascal IDE のコンポーネントウィンドウ Arrow icon Lazarus Pascal IDE の Main フォームウィンドウ


TSQLConnector コンポーネントの設定

Lazarus Pascal IDE の TSQLConnector コンポーネントは、アプリケーションと各種データベースまたはデータベース API との接続を容易にします。設定方法は以下のとおりです。

  1. Main フォームで TSQLConnector コンポーネントを選択します。
  2. オブジェクトインスペクターがまだ開いていない場合は、View > Object Inspector から開きます。
  3. 左側のオブジェクトインスペクターで、Properties セクションの以下のプロパティを設定します。
    プロパティ 値
    Connected True
    Driver ODBC
    DatabaseName DSN 名(例:CData Sage X3 Cloud Source)
    UserName データベースのユーザー名
    Password データベースのパスワード
    HostName Sage X3 Cloud URL またはローカルデータベースの場合は localhost
    LoginPrompt False
    Transaction TSQLTransaction コンポーネントを選択

認証情報にセキュリティトークンが必要な場合は、以下の手順に従ってください。

  1. Lazarus Pascal IDE で Main Form をダブルクリックしてコードエディタを開きます。
  2. procedure TForm1.FormCreate(Sender: TObject); セクションを見つけます。
  3. begin キーワードの下に以下のコードを貼り付けます。'your_security_token' を実際のセキュリティトークンに置き換えてください。
    
    SQLConnector1.Params.Values ['Password'] :=
      SQLConnector1.Params.Values ['Password'] + 'your_security_token';
    
Lazarus Pascal IDE の Main Form1 で選択された TSQLConnector コンポーネント Arrow icon Lazarus Pascal IDE のオブジェクトインスペクターでの TSQLConnector コンポーネントのプロパティ(Salesforce の例)



TSQLQuery コンポーネントの設定

Lazarus Pascal IDE の TSQLQuery コンポーネントは、クエリ用の SQL コードを受け取り、データベースからデータを取得することで、データ操作を簡素化します。以下の情報を使用して設定してください。

  1. Main フォームで TSQLQuery コンポーネントを選択します。
  2. オブジェクトインスペクターの Properties セクションで以下のプロパティを設定します。
    プロパティ 値
    Active True
    DataBase TSQLConnector コンポーネントの名前を選択
    SQL(3つの点をクリック) クエリ(例:SELECT * FROM BPCUSTOMER)
    Transaction TSQLTransaction コンポーネント

Lazarus Pascal IDE の Main Form2 で選択された TSQLQuery コンポーネント Arrow icon Lazarus Pascal IDE のオブジェクトインスペクターでの TSQLQuery コンポーネントのプロパティ(Salesforce の例)



TDataSource、TDBGrid、TSQLTransaction コンポーネントの設定

Lazarus Pascal IDE の TDataSource コンポーネントは、データセット(例:TSQLQuery)と TDBGrid などのデータ対応コントロールをつなぎ、データの表示と操作を可能にします。TDBGrid はデータを表形式で表示し、TSQLTransaction はトランザクション内でデータベース操作を実行することでデータの整合性を確保します。これら3つのコンポーネントの設定方法は以下のとおりです。

  1. TDataSource コンポーネントを選択し、DataSet プロパティに TSQLQuery コンポーネントの名前を設定します。
  2. TDBGrid コンポーネントを選択し、DataSource プロパティに TDataSource コンポーネントを設定します。
  3. TSQLTransaction コンポーネントを選択し、以下のプロパティを設定します。
    1. Active:True
    2. Database:TSQLConnector コンポーネントの名前
Lazarus Pascal IDE のオブジェクトインスペクターでの TDataSource コンポーネントのプロパティ Lazarus Pascal IDE のオブジェクトインスペクターでの TDBGrid コンポーネントのプロパティ Lazarus Pascal IDE のオブジェクトインスペクターでの TSQLTransaction コンポーネントのプロパティ


接続をテストするコードを追加

接続を正常にテストするには、以下のコードを使用してください。

  1. Main Form をダブルクリックしてソースエディタを開きます。
  2. begin キーワードの下、end. キーワードの前に以下のコードを追加します。

procedure TForm1.FormCreate(Sender: TObject);
begin
  // Code for your Security Token
    SQLConnector1.Params.Values ['Password'] :=
        SQLConnector1.Params.Values ['Password'] + 'your_security_token';
  try
    SQLConnector1.Open;
    ShowMessage('Connection successful!');
  except
    on E: Exception do
      ShowMessage('Error: ' + E.Message);
  end;

  try
    SQLQuery1.Open;
    if SQLQuery1.IsEmpty then
      ShowMessage('No data found.')
    else
      ShowMessage('Data loaded successfully.');
  except
    on E: Exception do
      ShowMessage('Error: ' + E.Message);
  end;
end;

end.
Lazarus Pascal IDE のソースエディタ

アプリケーションをコンパイルして実行

プロジェクトを保存します。Run > Compile、続いて Run に移動するか、ショートカット F9 を使用してアプリケーションを実行します。

Lazarus Pascal IDE で ODBC 接続成功 Lazarus Pascal IDE で ODBC データ読み込み成功 Lazarus Pascal IDE の Main フォームでの ODBC データ読み込みプレビュー


次のステップ:データを活用してみよう

データが Lazarus に正常にインポートされたので、その可能性を最大限に活用するためのアイデアをご紹介します。

  • TDBGrid を拡張:TDBGrid をカスタマイズして、ソート、編集、特定の行のハイライト表示を有効にしましょう。
  • データを可視化:TChart などのコンポーネントを使用して、直感的なデータ表現のためのグラフやチャートを作成しましょう。
  • フィルタと検索:TDBFilter などのコンポーネントを使用するか、カスタムフィルタロジックを実装して、ユーザーが関連するデータにすばやく集中できるようにしましょう。ユーザー入力用の TEdit コンポーネントを追加し、フィルタ機能にリンクさせます。
  • データをエクスポート:TSVExport や TFileStream コンポーネントを活用して、データを CSV や Excel などの形式で保存し、共有や他のシステムへの統合に利用しましょう。
  • 計算を実行:TFPCustomDataSet やデータセットの組み込み機能を使用して、合計、平均、その他の指標を計算しましょう。結果を TLabel に表示したり、TDBGrid に追加できます。
  • フォームとレポートを作成:TForm と TDBEdit を使用してユーザー操作用のインタラクティブなフォームを設計しましょう。レポートには、RLReport や FastReport などのコンポーネントを統合して、プロフェッショナル品質のレポートを生成・印刷できます。

これらの拡張機能で、データドリブンアプリケーションを次のレベルに引き上げましょう!



CData で Lazarus のデータ接続を簡素化

Lazarus Pascal 内でリアルタイムのSage X3 Cloud のデータの可能性を最大限に引き出しましょう。ワークフローを効率化し、生産性を高め、これまでにないシームレスな統合を体験してください。

今すぐ無償トライアルを開始して、データとの接続と作業の方法を変革しましょう!

はじめる準備はできましたか?

Sage X3 Cloud ODBC Driver の無料トライアルをダウンロードしてお試しください:

 ダウンロード

詳細:

Sage X3 Cloud Icon Sage X3 Cloud ODBC Driver

Sage X3 Cloud ODBC Driver は、ODBC 接続をサポートするさまざまなアプリケーションからSage X3 Cloud のリアルタイムデータ連携を実現するパワフルなツールです。

データベースにアクセスするときと同感覚でSage X3 Cloud データにアクセスし、標準ODBC Driver インターフェースを通じてSage X3 Cloud に読み出し、書き込み、更新が可能に。