UKG Pro WFM のデータを使ったCrystal Reports を発行

加藤龍彦
加藤龍彦
デジタルマーケティング
Report Wizard と標準のADO.NET を使用して最新のUKG Pro WFM のデータを使用したレポートを作成。



CData ADO.NET Provider for API は、Crystal Reports for Visual Studio 開発環境に統合されています。標準のADO.NET コンポーネントを使用して、SQL Server と同じようにレポートを作成でき、さらにUKG Pro WFM とリアルタイムで連携できます。この記事では、開いたときに更新されるレポートにUKG Pro WFM のデータを追加するために必要な3つのステップを完了する方法を説明します。

Note:このチュートリアルを実行するには、Crystal Reports とVisual Studio のデベロッパーバージョンをインストールしてください。

Crystal Reports アプリケーションを作成する

この記事を実行するにはVisual Studio Crystal Reports プロジェクトが必要になります。この記事では、WPF アプリケーションにレポートを追加します。「File」->「New Project」とクリックし、Crystal Reports WPF Application テンプレートを選択することで、作成できます。表示されるウィザードで空のレポートを作成するオプションを選択します。

UKG Pro WFM に接続する

Server Explorer からUKG Pro WFM のADO.NET データソースを作成すると、Crystal Reports ウィザードおよびCrystal Reports Designer で使用できるDataSet を簡単に作成できます。Server Explorer でUKG Pro WFM のデータを操作するためのガイドは、ヘルプドキュメントの「はじめに」の章を参照してください。

まず、Profile 接続プロパティをディスク上の UKGProWFM プロファイルの場所に設定します(例:C:\profiles\UKGProWFM.apip)。次に、ProfileSettings 接続プロパティを UKGProWFM の接続文字列に設定します(以下を参照)。

UKGProWFM API プロファイル設定

UKG Pro Workforce Management では、OAuth 2.0 の Resource Owner Password Credentials グラント(grant_type=password)を使用して API へのアクセスを認可します。一般的な OAuth ベースのプロファイルとは異なり、ブラウザでのリダイレクトや認可コードのステップはありません。ドライバーが UKG Pro WFM のユーザー名、パスワード、クライアント ID、クライアントシークレットを使って、直接アクセストークンを取得します。

認証するには、以下の接続プロパティを設定します。

  • AuthScheme:OAuthPassword に設定します。
  • Host:UKG Pro Workforce Management のデータセンター/テナントのホスト名に設定します(例:yourcompany.mykronos.com)。プロトコル(https://)や末尾のスラッシュは含めないでください。
  • OAuthClientId:UKG Pro Workforce Management の OAuth アプリケーションに発行されたクライアント ID に設定します。
  • OAuthClientSecret:UKG Pro Workforce Management の OAuth アプリケーションに発行されたクライアントシークレットに設定します。
  • User:UKG Pro Workforce Management のユーザー名に設定します。
  • Password:UKG Pro Workforce Management のパスワードに設定します。

アクセストークンは https://{Host}/api/authentication/access_token から取得します。UKG Pro Workforce Management が発行するリフレッシュトークンの有効期限は7日間です。リフレッシュトークン自体の期限切れによってトークンの更新に失敗した場合、ドライバーは User/Password の認証情報で再認証し、新しいアクセストークンを取得する必要があります。

接続を構成する際に、Max Rows 接続プロパティも設定できます。これにより返される行数が制限されるため、レポートやビジュアライゼーションをデザインするときのパフォーマンスを向上させることができます。

DataSet を作成する

以下のステップに従ってVisual Studio ADO.NET DataSet Designer を使用し、ADO.NET DataSet オブジェクトを作成します。Crystal Reports はUKG Pro WFM テーブルのメタデータを含むDataSet オブジェクトにバインドします。またこのアプローチでは、App.config に接続文字列が追加されることに注意してください。後にこの接続文字列を使用してデータをレポートにロードします。

  1. Solution Explorer でプロジェクトを右クリックし、「Add」->「New Item」をクリックします。
  2. DataSet を選択します。DataSet Designer が表示されます。
  3. Server Explorer からDataSet Designer にテーブルをドラッグ & ドロップします。この記事ではEmployees テーブルを使用します。

UKG Pro WFM フィールドをレポートに追加する

以下のステップに従って、DataSet からレポートにカラムを追加します。

  1. Solution Explorer で.rpt ファイルをダブルクリックし、Crystal Reports Designer を開きます。
  2. デザイナーを右クリックし、「Database」->「Database Expert」と進みます。
  3. Project Folder とADO.NET DataSets ノードを展開し、作成したDataSet を「Selected Tables」ボックスにドラッグします。これで、Field Explorer からフィールドにアクセスできます。
  4. Field Explorer からレポートの「Details」セクションまたは別のセクションにフィールドをドラッグ & ドロップします。
DataSet columns in a report.(Salesforce is shown.)

レポートにデータをロードする

メタデータのみを含むDataSet を作成したら、実際のデータを含むDataTable を作成する必要があります。APIDataAdapter を使用して、SQL クエリの結果をDataTable に入力できます。

  1. System.Configuration.dll への参照をプロジェクトに追加して、App.config から接続文字列を使用できるようにします。
  2. App.config で.NET 4.0 を使用する場合にCrystal Reports との互換性を保つため、次のコードを設定ノードに追加します。
    
      <startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
      </startup>
    
  3. Window.xaml.cs ファイルに以下の参照を追加します。

    using System.Configuration;
    using CrystalDecisions.CrystalReports.Engine;
    using CrystalDecisions.Shared;
    using System.Data.CData.API;
    using System.Data;
    
  4. 以下のWindow_Loaded メソッドをWindow.xaml.cs に追加し、DataTable を返すSQL クエリを実行します。最低でも、レポートで使用されているカラムと同じカラムは選択する必要があることに注意してください。

    private void Window_Loaded(object sender, RoutedEventArgs e) {
      ReportDocument report = new ReportDocument();
      report.Load("../../CrystalReport1.rpt");
     var connectionString = ConfigurationManager.ConnectionStrings["MyAppConfigConnectionStringName"].ConnectionString;
      using (APIConnection connection = new APIConnection(connectionString)) {
        APIDataAdapter dataAdapter = new APIDataAdapter(
        "SELECT PersonNumber, UserName FROM Employees WHERE PersonId = '12345'", connection);
         DataSet set = new DataSet("_set");
         DataTable table = set.Tables.Add("_table");
         dataAdapter.Fill(table);
         report.SetDataSource(table);
      }
      reportViewer.ViewerCore.ReportSource = report;
    }
    
  5. Window.xaml ファイルでLoaded イベントを追加し、Window タグを以下のようにします。

    
    <Window x:Class="CrystalReportWpfApplication4.Window1"
            xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
            xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
            xmlns:cr="clr-namespace:SAPBusinessObjects.WPF.Viewer;assembly=SAPBusinessObjects.WPF.Viewer"
            alt="WPF Crystal Report Viewer" Height="600" Width="800" Loaded="Window_Loaded">
            ...
    </Window>
    
  6. レポートを実行します。レポートが読み込まれると、プロバイダはクエリを実行して現在のデータを取得します。 A report that loads the current data when opened.(Salesforce is shown.)

UKG Pro WFM のデータのチャートを作成する

Chart Expert などのエキスパートとともにDataSet を使用することもできます。

  1. Crystal Reports Designer を右クリックして「Insert」->「Chart」とクリックします。
  2. 「Report Header」または「Report Footer」セクションを選択します。Chart Expert が表示されます。
  3. 「Type」タブでチャートタイプを選択します。この記事では、サイドバイサイドの棒グラフを使用します。
  4. 「Data」タブでx 軸のカラムと条件を選択します。例えば、DataSet ノードのPersonNumber カラムを「On Change Of」メニューの下のボックスにドラッグします。
  5. x 軸のカラムを選択し、「TopN」ボタンと「Order」ボタンをクリックして並べ替えと制限を構成します。
  6. y 軸のカラムとサマリー操作を選択します。例えば、DataSet ノードのUserName カラムを「Show Values」ボックスにドラッグします。
  7. レポートを実行します。

Crystal Reports は、UKG Pro WFM API などに対してGROUP BY を実行する代わりに、DataTable にロード済みのデータに対して集計を実行することに注意してください。これは、レポート作成ウィザードにも当てはまります。

別のDataSet を作成し、他のクエリを入力することで、UKG Pro WFM に対して実行されるクエリをより細かく制御できます。ドライバのSQL エンジンの詳細については、ヘルプドキュメントを参照してください。

DataSet columns to be added to a chart.(Salesforce is shown.)

はじめる準備はできましたか?

API Driver で UKG Pro WFM のライブデータに接続

UKG Pro WFM に接続