Power View でのCleverPush のデータのインポートとビジュアライズ

古川えりか
古川えりか
コンテンツスペシャリスト
Excel でCleverPush のデータを使ったデータビジュアライゼーションを作成します。



Excel に組み込まれているODBC サポートを使用して、CleverPush のデータを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、CleverPush をPower View レポートにインポートする方法を説明します。

CData ODBC ドライバとは?

CData ODBC ドライバは、以下のような特徴を持ったリアルタイムデータ連携ソリューションです。

  1. CleverPush をはじめとする、CRM、MA、会計ツールなど多様なカテゴリの270種類以上のSaaS / オンプレミスデータソースに対応
  2. 多様なアプリケーション、ツールにCleverPush のデータを連携
  3. ノーコードでの手軽な接続設定
  4. 標準 SQL での柔軟なデータ読み込み・書き込み

CData ODBC ドライバでは、1.データソースとしてCleverPush の接続を設定、2.Power View 側でODBC Driver との接続を設定、という2つのステップだけでデータソースに接続できます。以下に具体的な設定手順を説明します。

CData ODBC ドライバのインストールとCleverPush への接続設定

まずは、本記事右側のサイドバーからAPI ODBC Driver の無償トライアルをダウンロード・インストールしてください。30日間無償で、製品版の全機能が使用できます。

未指定の場合は、初めにODBC DSN で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。

まず、Profile 接続プロパティをディスク上の Cleverpush プロファイルの場所に設定します(例:C:\profiles\Cleverpush.apip)。次に、ProfileSettings 接続プロパティを Cleverpush の接続文字列に設定します(以下を参照)。

Cleverpush API プロファイル設定

CleverPush では、プライベート API キーでリクエストを認証します。API キーは、すべての API 呼び出しで Authorization リクエストヘッダーの値として渡されます。

プライベート API キーは、CleverPush ダッシュボードの「Settings」>「API」で確認できます。サーバーサイドからアクセスする場合は、パブリックキーではなくプライベートキーを使用してください。

以下の接続プロパティを設定すると、接続できるようになります。

  • AuthScheme:APIKey に設定します。
  • APIKey:CleverPush のプライベート API キーに設定します。

オプションの接続プロパティ

  • ChannelId:デフォルトで使用する CleverPush のチャネル識別子に設定します。ほとんどのテーブルではチャネルによるフィルタが必要です。このプロパティを設定しておくと、WHERE 句で毎回 ChannelId を指定しなくてもクエリを実行できます。

DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。

Data Connection Wizard で接続

以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。

  1. [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
  2. [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
  3. リストから[ODBC DSN for API]を選択します。
  4. 操作するテーブルを選択します。

    複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。

  5. [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
  6. [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。

テーブルの作成

テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。

A table with a filter applied.(Salesforce is shown.)

データのビジュアライゼーションを作成

[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。

The table of data represented as a stacked bar chart.(Salesforce is shown.)

CleverPush からPower View へのデータ連携には、ぜひCData ODBC ドライバをご利用ください

このようにCData ODBC ドライバと併用することで、270を超えるSaaS、NoSQL データをコーディングなしで扱うことができます。30日の無償評価版が利用できますので、ぜひ自社で使っているクラウドサービスやNoSQL と合わせて活用してみてください。

CData ODBC ドライバは日本のユーザー向けに、UI の日本語化、ドキュメントの日本語化、日本語でのテクニカルサポートを提供しています。

はじめる準備はできましたか?

API Driver で CleverPush のライブデータに接続

CleverPush に接続