WCF でSage X3 Cloud の OData サービスを公開する方法

Jerod Johnson
Jerod Johnson
Director, Technology Evangelism
この記事では、WCF サービスアプリケーションを開発してSage X3 Cloud のデータの OData フィードを生成する方法を解説します。



CData ADO.NET Provider for Sage X3 Cloud を使用すると、Windows Communication Foundation(WCF)フレームワークを活用してサービス指向アプリケーションを素早く開発し、Sage X3 Cloud のデータを OData コンシューマーに提供できます。この記事では、接続用の Entity Data Model を作成し、WCF Data Service を構成して OData サービスを公開する方法を解説します。公開したフィードは、Power Pivot や CData ADO.NET Provider for OData を使用するアプリケーションなど、さまざまな OData クライアントから利用できます。

OData サービスの作成

以下の手順で、OData 経由でSage X3 Cloud のデータへの接続を提供する WCF サービスアプリケーションを作成します。

  1. Visual Studio を開き、新しいプロジェクトを作成します。WCF Service Application テンプレートを選択します。
  2. 自動生成された IService.cs と Service1.svc を削除します。
  3. Entity Framework 6 をインストールします:

    Visual Studio のパッケージマネージャーコンソールを使用して、最新バージョンの Entity Framework をインストールします。以下のコマンドを実行すると、Entity Framework が自動的にダウンロード・インストールされます。

    Install-Package EntityFramework
  4. Entity Framework プロバイダーを登録します:
    1. App.config または Web.config ファイルの "providers" セクションに、以下のプロバイダーエントリを追加します。Entity Framework のインストールが成功していれば、このセクションはすでに存在しているはずです。
      
      <configuration>
      ...
      <entityFramework>
        <providers>
          ...
          <provider invariantName="System.Data.CData.SageX3Cloud" type="System.Data.CData.SageX3Cloud.SageX3CloudProviderServices, System.Data.CData.SageX3Cloud.Entities.EF6" />
        </providers>
      </entityFramework>
      </configuration>
    2. インストールディレクトリの lib/4.0 にある System.Data.CData.SageX3Cloud.Entities.dll への参照を追加します。
    3. プロジェクトをビルドして、EF6 のセットアップを完了します。
  5. Project -> Add New Item -> ADO.NET Entity Data Model をクリックします。
  6. 表示される Entity Data Model ウィザードで、'EF Designer from Database' オプションを選択します。
  7. Choose Your Connection ダイアログが表示されたら、New Connection をクリックします。
  8. Connection properties ダイアログで、CData Sage X3 Cloud Data Source を選択し、必要な認証情報を入力します。

    一般的な接続文字列は以下のとおりです:

    AuthScheme=OAuth;URL=https://x3server/;OAuthAccessTokenUrl=https://auth-domain/oauth/token;OAuthClientId=your_client_id;OAuthClientSecret=your_client_secret;Audience=https://api-audience;XAPIKey=your_api_key;Folder=SEED;

    Sage X3 Cloud では OAuth 2.0 の Client Credentials フローを使用し、API へのアクセスには X-API-Key も必要です。AuthScheme を OAuth に設定し、以下の接続プロパティを指定します。

    • URL:Sage X3 Cloud インスタンスのベース URL。
    • OAuthAccessTokenUrl:OAuth トークンエンドポイント(例:https://your-auth-domain/oauth/token)。
    • OAuthClientId:OAuth アプリケーションのクライアント ID。
    • OAuthClientSecret:OAuth アプリケーションのクライアントシークレット。
    • Audience:トークンリクエストで使用する API の Audience 値。
    • XAPIKey:Sage X3 Cloud の管理者から提供された X-API-Key。
    • Folder:Sage X3 のフォルダ名(例:SEED)。このフォルダがデフォルトのスキーマとして使用されます。
    • Folders(オプション):Sage X3 フォルダのカンマ区切りリスト(例:SEED,PERF)。各フォルダが個別のスキーマとして公開されるため、Schema.Table 構文でフォルダをまたいだクエリを実行できます。

    ドライバーは Client Credentials フローでアクセストークンを取得し、すべての API リクエストで X-API-Key とあわせて送信します。InitiateOAuth を GETANDREFRESH(デフォルト)に設定しておけば、トークンの取得と更新は自動で行われます。

    Add Connection ダイアログで指定する接続プロパティ。(Salesforce の例)
  9. OData クライアントからアクセスさせたい Sage X3 Cloud のテーブルとビューを選択します。 Entity Data Model ウィザードで利用可能なテーブル。(Salesforce の例)
  10. Project -> Add New Item -> WCF Data Service をクリックします。
  11. データソースクラスを指定し、新しい WCF Data Service へのアクセスを構成します。以下の例では、エンティティの Access Rule が All に設定されています。これは、すべてのユーザーがデータの読み取りと変更を行えることを意味します。

    able to read and modify data.
    
      
    using System;
    using System.Collections.Generic;
    using System.Data.Services;
    using System.Data.Services.Common;
    using System.Linq;
    using System.ServiceModel.Web;
    using System.Web;
    
    namespace SageX3CloudService{
      public class SageX3CloudDataService : DataService<SageX3CloudEntities> {
        public static void InitializeService(DataServiceConfiguration config) {
          config.SetEntitySetAccessRule("*", EntitySetRights.All);
          config.DataServiceBehavior.MaxProtocolVersion = DataServiceProtocolVersion.V3;
        }
      }
    }
    	
  12. プロジェクトを実行します。これで、OData 対応アプリケーションから Salesforce データにアクセスし、変更を反映できるようになります。ブラウザでフィードにアクセスできます。フィードは次のように表示されます: 生の OData フィード。(Salesforce の例)

Power Pivot から OData サービスを利用する

これで、任意の OData クライアント(例:Excel Power Pivot)からサービスを利用できます。

  1. Excel を開き、Power Pivot Window ボタンをクリックします。
  2. 新しいポップアップが表示されます。From Data Feeds オプションを選択します。
  3. 表示される Table Import Wizard で、OData URL を入力します(例:http://localhost:12449/SageX3CloudDataService.svc/)。 Sage X3 Cloud の OData URL。
  4. OData サービスへの接続後、ウィンドウ下部の Next ボタンをクリックします。
  5. ウィザードの次のウィンドウに、利用可能なテーブルの一覧が表示されます。インポートするテーブルを選択し、Finish をクリックします。 Table Import Wizard で利用可能なテーブル。(Salesforce の例)
  6. Close をクリックして、Power Pivot にデータをインポートします。 Power Pivot にロードされたテーブル。(Salesforce の例)

はじめる準備はできましたか?

Sage X3 Cloud Data Provider の無料トライアルをダウンロードしてお試しください:

 ダウンロード

詳細:

Sage X3 Cloud Icon Sage X3 Cloud ADO.NET Provider

Sage X3 Cloud 連携のパワフルな.NET アプリケーションを素早く作成して配布。