Power View でのUKG Pro HCM のデータのインポートとビジュアライズ
Excel に組み込まれているODBC サポートを使用して、UKG Pro HCM のデータを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、UKG Pro HCM をPower View レポートにインポートする方法を説明します。
CData ODBC ドライバとは?
CData ODBC ドライバは、以下のような特徴を持ったリアルタイムデータ連携ソリューションです。
- UKG Pro HCM をはじめとする、CRM、MA、会計ツールなど多様なカテゴリの270種類以上のSaaS / オンプレミスデータソースに対応
- 多様なアプリケーション、ツールにUKG Pro HCM のデータを連携
- ノーコードでの手軽な接続設定
- 標準 SQL での柔軟なデータ読み込み・書き込み
CData ODBC ドライバでは、1.データソースとしてUKG Pro HCM の接続を設定、2.Power View 側でODBC Driver との接続を設定、という2つのステップだけでデータソースに接続できます。以下に具体的な設定手順を説明します。
CData ODBC ドライバのインストールとUKG Pro HCM への接続設定
まずは、本記事右側のサイドバーからAPI ODBC Driver の無償トライアルをダウンロード・インストールしてください。30日間無償で、製品版の全機能が使用できます。
未指定の場合は、初めにODBC DSN で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。
まず、Profile 接続プロパティをディスク上の UKGProHCM プロファイルの場所に設定します(例:C:\profiles\UKGProHCM.apip)。次に、ProfileSettings 接続プロパティを UKGProHCM の接続文字列に設定します(以下を参照)。
UKGProHCM API プロファイル設定
UKG Pro HCM では、Basic 認証とカスタマー API キーを組み合わせて API へのアクセスを認可します。接続には、UKG Pro HCM の認証情報と、UKG が発行したカスタマー API キーが必要です。
認証するには、以下の接続プロパティを設定します。
- AuthScheme:Basic に設定します。
- User:UKG Pro HCM のユーザー名に設定します。
- Password:UKG Pro HCM のパスワードに設定します。
- ProfileSettings:以下の項目をセミコロン区切りで指定します。
- Host:UKG Pro HCM テナントのホスト名(例:yourcompany.ultipro.com)。
- CustomerAPIKey:UKG のカスタマー API キー。各 API 呼び出しで US-CUSTOMER-API-KEY リクエストヘッダーとして渡されます。
カスタマー API キーの入手方法については、UKG Pro HCM の管理者にお問い合わせいただくか、UKG Developer Portal(https://developer.ukg.com)をご参照ください。
DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。
Data Connection Wizard で接続
以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。
- [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
- [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
- リストから[ODBC DSN for API]を選択します。
操作するテーブルを選択します。
複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。
- [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
- [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。
テーブルの作成
テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。
データのビジュアライゼーションを作成
[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。
UKG Pro HCM からPower View へのデータ連携には、ぜひCData ODBC ドライバをご利用ください
このようにCData ODBC ドライバと併用することで、270を超えるSaaS、NoSQL データをコーディングなしで扱うことができます。30日の無償評価版が利用できますので、ぜひ自社で使っているクラウドサービスやNoSQL と合わせて活用してみてください。
CData ODBC ドライバは日本のユーザー向けに、UI の日本語化、ドキュメントの日本語化、日本語でのテクニカルサポートを提供しています。