CData Power BI Connector for JD Edwards はじめに:インストールから接続まで
このガイドでは、CData Power BI Connector for JD Edwards の使い方を詳しく解説します。コネクタのインストールとライセンス認証、初回接続の設定、そしてアプリケーションで JD Edwards のデータ を操作するための次のステップをご紹介します。
インストールとライセンス認証
CData Power BI Connector for JD Edwards を使用すると、Power BI Desktop および Power BI オンプレミスデータゲートウェイからライブの JD Edwards のデータ に直接接続できます。このセクションでは、インストールの前提条件、プラットフォームサポート、コネクタのデプロイ、およびライセンス要件について詳しく説明します。
Power BI On-premises Data Gateway to connect directly to live JD Edwards のデータ. This section details installation prerequisites, platform support, connector deployment, and licensing requirements.システム要件
このコネクタは、Microsoft Power BI Desktop および Power BI Gateway が利用可能な環境でサポートされています。これらのコンポーネントは Windows 専用のため、Power BI Connector は Windows プラットフォームのみでサポートされています。
Power BI Gateway are available. Because these components are Windows-only, the Power BI Connector is supported exclusively on Windows platforms.オペレーティングシステムのサポート
- Windows 10(64 ビット)
- Windows 11(64 ビット)
- Windows Server 2016、2019、または 2022(Power BI Gateway デプロイメントに推奨)
Power BI コンポーネント
- Power BI Desktop(最新バージョンを推奨):レポートのデザイン、データモデリング、およびコネクタの設定に使用します。
- Power BI オンプレミスデータゲートウェイ:スケジュール更新またはクラウドに公開されたデータセットに必要です。
ソフトウェアの依存関係
Microsoft Visual C++ 2015-2022 再頒布可能パッケージ(まだインストールされていない場合は自動的にインストールされます)。
Power BI Connector のインストール
Windows
- CData Power BI Connector for JD Edwards をダウンロードします。
- インストーラーを実行し、インストールウィザードに従います。
- インストーラーがセットアッププロセスを案内し、コネクタをデフォルトのインストールディレクトリにデプロイします。
- インストール中にライセンスキーの入力を求められる場合があります。
- ライセンスキーは CData Orders チームからメールで届いているはずです。
- ライセンスキーは次のような形式です:XXXX-XXXX-XXXX-XXXX-XXXX
Note:試用版を実行する場合は、Trial Key オプションを選択してください。
- インストール後、以下の場所でコネクタファイルを確認します: C:\Program Files\CData\CData Power BI Connector for JDEdwards\CData.JDEdwards.pqx
- .pqx ファイルを Power BI Desktop のカスタムコネクタフォルダにコピーします(初回のみ): Documents\Power BI Desktop\Custom Connectors
- Power BI Desktop を再起動します。カスタム拡張機能を有効にするよう求められた場合:
- ファイル -> オプションと設定 -> オプション を選択します
- セキュリティを選択します
- データ拡張機能で「検証なしで任意の拡張機能の読み込みを許可する」を選択します
- Power BI Desktop を再起動します
- Power BI Gateway デプロイメントの場合は、同じ .pqx ファイルをゲートウェイのカスタムコネクタディレクトリにコピーし、ゲートウェイサービスを再起動して読み込みます。
ライセンスの認証
CData Orders チームからメールでライセンスキーを受け取っているはずです。 ライセンスキーは次のような形式です:XXXX-XXXX-XXXX-XXXX-XXXX
Windows でのライセンス認証
通常、ライセンスはインストール中に認証されます。ただし、手動での認証が必要な場合があります。以下の手順で Power BI Connector の手動認証を行います:
- スタートメニューから ODBC ドライバーアプリケーション(DSN)を開きます。
- ユーザー DSN または システム DSN を選択し、CData PBI JD Edwards Source/Sys を開きます。
- About タブに移動します。
- License Information セクションの Activation フィールドにライセンスキーを入力し、Activate! をクリックします。
- 認証が成功すると、コネクタに「Licensed」ステータスが表示されます。OK をクリックします。
ライセンスに関するよくある質問
ライセンスは複数のマシンで使用できますか?
はい、サブスクリプションプランによります。注文確認メールを確認するか、アカウント担当者にお問い合わせください。アカウント担当者が不明な場合は、[email protected] までお問い合わせください。
ライセンスキーを紛失しました。どうすれば取得できますか?
注文番号を添えて [email protected] までメールでお問い合わせいただければ、ライセンスキーを再送いたします。
ライセンスを別のマシンに移行できますか?
はい。ライセンスを別のマシンに移行するには、以下のリンクからライセンス移行リクエストを送信する必要があります:
ライセンス移行リクエストが送信され、正常に処理されると、プロダクトキーにアクティベーションが追加され、別のマシンで正規ライセンスを認証できるようになります。このプロセスが完了すると、以前のマシンのライセンスは無効になります。
ライセンスに関するその他のご質問は、[email protected] までお問い合わせください。ライセンスの確認とアップグレードは、セルフサービスポータル portal.cdata.com から行えます。
接続設定
ドライバーがインストールされ、ライセンスが認証されたら、JD Edwards への接続を設定できます。CData Power BI Connector for JD Edwards は ODBC ドライバー上に構築されているため、DSN(データソース名)を使用して接続プロパティを保存します。
DSN の作成
Windows:ODBC データソース アドミニストレーターの使用
- ODBC データソース アドミニストレーター(64 ビット)を開きます
Note:CData Power BI Connector は 64 ビット版を使用します。
- Windows スタートメニューで「ODBC」と検索します
- または、コントロールパネル -> 管理ツール -> ODBC データソース に移動します
- システム DSN または ユーザー DSN タブをクリックします
- システム DSN:マシン上のすべてのユーザーが利用可能(サービス用に推奨)
- ユーザー DSN:現在のユーザーのみ利用可能
- リストから CData PBI JD Edwards Source または Sys(ユーザー DSN またはシステム DSN に応じて)を選択するか、追加をクリックして新しいデータソースを作成します。
- 完了をクリックして接続設定ダイアログを開きます。
接続プロパティの設定
ドライバーは Application Interface Services(AIS)Server を経由して JD Edwards に接続します。以下の接続プロパティを設定します。
- URL:AIS Server のベース HTTPS URL(例:https://jde-ais.example.com:8300)。
- User:JD Edwards のユーザー名。
- Password:JD Edwards のパスワード。
- Environment(オプション):使用する JD Edwards の環境(例:本番環境なら PD920、開発環境なら DV920)。指定しない場合は、AIS Server のデフォルト環境が使用されます。
- Role(オプション):セッションで使用する JD Edwards のロール。指定しない場合は、AIS Server のデフォルトロールが使用されます。
- DeviceName(オプション):接続元のデバイスまたはアプリケーションの識別子。AIS Server での監査やログ記録に使用されます。
- Jasserver(オプション):リクエストのルーティング先となる Java Application Server(JAS)インスタンス。クラスタ環境で便利です。
公開するデータの選択
JD Edwards ではテーブルとビジネスビューが System Code ごとに整理されており、ドライバーは各 System Code をそれぞれ個別のスキーマとして公開します。利用できるスキーマは、以下のプロパティで制御できます。
- DataModel:System Code をスキーマとして公開する ERP モジュール(カンマ区切りで複数指定可)。接続先インスタンスのすべての System Code を公開する場合は All を指定します。デフォルトは FinancialManagement です。
- SystemCodes:DataModel の System Code に加えて公開したい System Code のカンマ区切りリスト(例:42,43)。
接続時、ドライバーは認証情報を AIS Server に送信してセッショントークンを取得し、キャッシュします。セッションの有効期限が切れる前に、新しいトークンが自動でリクエストされます。
接続テスト
- 接続プロパティを入力したら、接続テストをクリックします。
- テストが成功すると、以下が確認されます:
- 認証情報が正しいこと
- ネットワーク接続が確立されていること
- 必要な権限が設定されていること
- テストが失敗した場合、エラーメッセージに修正が必要な内容が表示されます。
- OK をクリックして DSN を保存します。
Power BI Desktop での接続作成
- Power BI Desktop を開きます。
- データの取得 -> その他を選択します。
- 検索ボックスに CData JD Edwards と入力します。
- CData JD Edwards コネクタを選択し、接続をクリックします。
- データソース名を入力します(この場合は CData PBI JD Edwards Sys)。
- データのコピーをプロジェクトにインポートする場合は インポートを選択します。このデータはオンデマンドで更新できます。または、リモートデータを操作する場合は DirectQuery を選択します。
- ナビゲーターダイアログで必要なテーブルを選択します。読み込みをクリックして Power BI で JD Edwards のデータ を表示します。
よくある接続の問題
認証エラー
解決策: 資格情報が最新であることを確認してください。OAuth アプリケーションの場合、アプリケーションのセキュリティ設定で CData を認可する必要がある場合があります。認可のサポートについては [email protected] までお問い合わせください。
サーバーに接続できない
解決策: ファイアウォールとプロキシ設定を確認してください。特定のポート要件については [email protected] までお問い合わせください。
テーブルが見つからない
解決策: データベース名とスキーマ名を確認してください。DSN 設定のデータモデルタブを使用して、利用可能なテーブルを参照してください。
接続に関するその他のトラブルシューティングについては、具体的なエラーメッセージを添えて [email protected] までお問い合わせください。
次のステップ
ドライバーのインストール、ライセンス認証、接続設定が完了しました。以下のシナリオを参考に、Power BI Connector をさらに活用してみてください:
| Power BI | 記事タイトル |
|---|---|
| Power BI + Power Apps | 【ノーコード】Power Apps データフローを使ってJD Edwards のデータをDataverse に連携する方法 |
| Power BI Dataflow | Power BI データフローでJD Edwards のデータを分析用にデータプレパレーション |
| Power BI Dataflows | PowerBI.com でJD Edwards Dataflows を作成 |
| Power BI Desktop | 【完全ガイド】Power BI × JD Edwards連携 - SQLなしでJD Edwardsのデータを分析・可視化 |
| Power BI Gateway | JD Edwards のデータをリアルタイムでPowerBI.com にパブリッシュ(発行) |
| Power BI Report Builder | Power BI Report Builder でリアルタイムのJD Edwards のデータを Power BI Service に可視化 |
| Power BI Setup | CData Power BI Connector for JD Edwards はじめに:インストールから接続まで |
インストールとライセンス
コネクタのインストールには管理者権限が必要ですか?
はい。CData Power BI Connector のインストールには管理者権限が必要です。インストーラーがシステムディレクトリに書き込み、必要なコンポーネントを登録するためです。
コネクタは 32 ビット版と 64 ビット版の両方がありますか?
いいえ。Power BI Desktop は 64 ビットのみで、すべての CData Power BI Connector は 64 ビット専用の MSI インストーラーとして配布されています。
サポート
ご不明な点がございましたら、お気軽にお問い合わせください:
- テクニカルサポート: [email protected]
- コミュニティフォーラム: CData Community Site
- ヘルプドキュメント: ローカルにインストールされているほか、オンラインでも参照可能です
接続
システム DSN とユーザー DSN の違いは何ですか?
システム DSN はマシン上のすべてのユーザーが利用でき、Power BI オンプレミスデータゲートウェイを使用する場合に必要です。ユーザー DSN は作成した Windows ユーザーのみが利用でき、ローカルの Power BI Desktop 使用に適しています。
DSN を作成する代わりに DSN レス接続文字列を使用できますか?
はい。基盤となる ODBC ドライバーは DSN レス接続文字列をサポートしており、Power BI は ODBC コネクタ経由で接続する際に DSN レス設定を使用できます。
例:
Driver={CData Power BI Connector for JDEdwards};User=Value1;Password=Value2;SecurityToken=Value3;
(正確なプロパティは JD Edwards の認証方法によって異なります。)
複数の JD Edwards アカウントに接続するにはどうすればよいですか?
JD Edwards アカウントごとに個別の DSN を作成するか、Power BI 内で異なる認証情報を使用して個別の接続エントリを作成します。各 DSN または接続は独自の設定を保存します。
プロキシサーバー経由で接続できますか?
はい。プロキシ設定は DSN の接続プロパティまたは Power BI のコネクタの詳細設定で構成できます。
必要なプロパティとサポートされているプロキシシナリオについては、ドキュメントの Firewall & Proxy セクションを参照してください。
パフォーマンスとトラブルシューティング
クエリが遅いのはなぜですか?
以下を確認してください:
- 大規模なデータセットや複雑な変換を行う場合は、インポートモードを使用してください。インポートモードはデータをローカルにキャッシュし、ライブ API 呼び出しの回数を減らします。
- DirectQuery はリアルタイムデータが必要な場合のみ使用してください。すべてのクエリが JD Edwards にリアルタイムで送信されます。
- 読み込み前にデータセットのサイズを削減するため、Power Query でフィルターを適用してください。
- 必要なカラムのサブセットのみ必要な場合は、すべてのカラムを選択しないでください。
- JD Edwards API の制限を監視してください。パフォーマンスが制限される場合があります。
- クエリ最適化とベストプラクティスについては [email protected] までお問い合わせください。
トラブルシューティング用のログを有効にするにはどうすればよいですか?
ログは Power BI Desktop のコネクタの詳細接続プロパティで有効にできます。
接続ダイアログで:
- 詳細オプションを展開します
- 以下を設定します:
- Logfile = 書き込み可能なログファイルへのパス
- Verbosity = 3(詳細なログの場合はそれ以上)
分析のために [email protected] にお問い合わせの際は、ログファイルを安全にアップロードしてください。
コネクタにはどのポートへのアクセスが必要ですか?
ほとんどの JD Edwards 接続では、アウトバウンド HTTPS(ポート 443)アクセスが必要です。ファイアウォールで JD Edwards エンドポイントへのアウトバウンドセキュアトラフィックを許可していることを確認してください。
プロキシや追加のセキュリティレイヤーを使用している環境では、コネクタドキュメントの Firewall & Proxy セクションを参照してください。
コネクタを Linux コンテナや Docker で使用できますか?
いいえ。CData Power BI Connector は Linux コンテナでは使用できません:
- Power BI Desktop は Windows でのみ動作します
- Power BI Gateway は Windows でのみ動作します
- カスタムコネクタ .pqx ファイルは Windows でのみサポートされています
Power BI Connector は Windows 専用のコンポーネントです。
一般
サポートされている SQL 操作の完全なリストはどこで確認できますか?
JD Edwards コネクタドキュメントの SQL Compliance セクションを参照してください。 Power BI エンジンの制限により、インポートモードと DirectQuery モードで利用可能な SQL 機能が異なる場合があります。
コネクタはどのくらいの頻度で更新されますか?
CData は Power BI Connector のメジャーアップデートを毎年リリースし、必要に応じて定期的なメンテナンスアップデートを行います。
最新バージョンについては、CData アカウントポータルを確認するか、[email protected] までお問い合わせください。
コネクタの使用例はどこで確認できますか?
ヘルプドキュメントの Power BI Getting Started および Examples セクションを参照してください。
(Note:Power BI Connector は、ODBC ドライバーや JDBC ドライバーのようなプログラミング言語のコードサンプルを使用しません。)
この FAQ で解決しない場合は、[email protected] までお問い合わせください。