JD Edwards のデータを使ったCrystal Reports を発行
CData ADO.NET Provider for JDEdwards は、Crystal Reports for Visual Studio 開発環境に統合されています。標準のADO.NET コンポーネントを使用して、SQL Server と同じようにレポートを作成でき、さらにJD Edwards とリアルタイムで連携できます。この記事では、開いたときに更新されるレポートにJD Edwards のデータを追加するために必要な3つのステップを完了する方法を説明します。
Note:このチュートリアルを実行するには、Crystal Reports とVisual Studio のデベロッパーバージョンをインストールしてください。
Crystal Reports アプリケーションを作成する
この記事を実行するにはVisual Studio Crystal Reports プロジェクトが必要になります。この記事では、WPF アプリケーションにレポートを追加します。「File」->「New Project」とクリックし、Crystal Reports WPF Application テンプレートを選択することで、作成できます。表示されるウィザードで空のレポートを作成するオプションを選択します。
JD Edwards に接続する
Server Explorer からJD Edwards のADO.NET データソースを作成すると、Crystal Reports ウィザードおよびCrystal Reports Designer で使用できるDataSet を簡単に作成できます。Server Explorer でJD Edwards のデータを操作するためのガイドは、ヘルプドキュメントの「はじめに」の章を参照してください。
ドライバーは Application Interface Services(AIS)Server を経由して JD Edwards に接続します。以下の接続プロパティを設定します。
- URL:AIS Server のベース HTTPS URL(例:https://jde-ais.example.com:8300)。
- User:JD Edwards のユーザー名。
- Password:JD Edwards のパスワード。
- Environment(オプション):使用する JD Edwards の環境(例:本番環境なら PD920、開発環境なら DV920)。指定しない場合は、AIS Server のデフォルト環境が使用されます。
- Role(オプション):セッションで使用する JD Edwards のロール。指定しない場合は、AIS Server のデフォルトロールが使用されます。
- DeviceName(オプション):接続元のデバイスまたはアプリケーションの識別子。AIS Server での監査やログ記録に使用されます。
- Jasserver(オプション):リクエストのルーティング先となる Java Application Server(JAS)インスタンス。クラスタ環境で便利です。
公開するデータの選択
JD Edwards ではテーブルとビジネスビューが System Code ごとに整理されており、ドライバーは各 System Code をそれぞれ個別のスキーマとして公開します。利用できるスキーマは、以下のプロパティで制御できます。
- DataModel:System Code をスキーマとして公開する ERP モジュール(カンマ区切りで複数指定可)。接続先インスタンスのすべての System Code を公開する場合は All を指定します。デフォルトは FinancialManagement です。
- SystemCodes:DataModel の System Code に加えて公開したい System Code のカンマ区切りリスト(例:42,43)。
接続時、ドライバーは認証情報を AIS Server に送信してセッショントークンを取得し、キャッシュします。セッションの有効期限が切れる前に、新しいトークンが自動でリクエストされます。
接続を構成する際に、Max Rows 接続プロパティも設定できます。これにより返される行数が制限されるため、レポートやビジュアライゼーションをデザインするときのパフォーマンスを向上させることができます。
DataSet を作成する
以下のステップに従ってVisual Studio ADO.NET DataSet Designer を使用し、ADO.NET DataSet オブジェクトを作成します。Crystal Reports はJD Edwards テーブルのメタデータを含むDataSet オブジェクトにバインドします。またこのアプローチでは、App.config に接続文字列が追加されることに注意してください。後にこの接続文字列を使用してデータをレポートにロードします。
- Solution Explorer でプロジェクトを右クリックし、「Add」->「New Item」をクリックします。
- DataSet を選択します。DataSet Designer が表示されます。
- Server Explorer からDataSet Designer にテーブルをドラッグ & ドロップします。この記事ではAccountsPayable.AccountLedger テーブルを使用します。
JD Edwards フィールドをレポートに追加する
以下のステップに従って、DataSet からレポートにカラムを追加します。
- Solution Explorer で.rpt ファイルをダブルクリックし、Crystal Reports Designer を開きます。
- デザイナーを右クリックし、「Database」->「Database Expert」と進みます。
- Project Folder とADO.NET DataSets ノードを展開し、作成したDataSet を「Selected Tables」ボックスにドラッグします。これで、Field Explorer からフィールドにアクセスできます。
- Field Explorer からレポートの「Details」セクションまたは別のセクションにフィールドをドラッグ & ドロップします。
レポートにデータをロードする
メタデータのみを含むDataSet を作成したら、実際のデータを含むDataTable を作成する必要があります。JDEdwardsDataAdapter を使用して、SQL クエリの結果をDataTable に入力できます。
- System.Configuration.dll への参照をプロジェクトに追加して、App.config から接続文字列を使用できるようにします。
- App.config で.NET 4.0 を使用する場合にCrystal Reports との互換性を保つため、次のコードを設定ノードに追加します。
<startup useLegacyV2RuntimeActivationPolicy="true"> <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/> </startup> Window.xaml.cs ファイルに以下の参照を追加します。
using System.Configuration; using CrystalDecisions.CrystalReports.Engine; using CrystalDecisions.Shared; using System.Data.CData.JDEdwards; using System.Data;
-
以下のWindow_Loaded メソッドをWindow.xaml.cs に追加し、DataTable を返すSQL クエリを実行します。最低でも、レポートで使用されているカラムと同じカラムは選択する必要があることに注意してください。
private void Window_Loaded(object sender, RoutedEventArgs e) { ReportDocument report = new ReportDocument(); report.Load("../../CrystalReport1.rpt"); var connectionString = ConfigurationManager.ConnectionStrings["MyAppConfigConnectionStringName"].ConnectionString; using (JDEdwardsConnection connection = new JDEdwardsConnection(connectionString)) { JDEdwardsDataAdapter dataAdapter = new JDEdwardsDataAdapter( "SELECT DocumentNumber, Amount FROM AccountsPayable.AccountLedger WHERE BusinessUnit = '100'", connection); DataSet set = new DataSet("_set"); DataTable table = set.Tables.Add("_table"); dataAdapter.Fill(table); report.SetDataSource(table); } reportViewer.ViewerCore.ReportSource = report; } Window.xaml ファイルでLoaded イベントを追加し、Window タグを以下のようにします。
<Window x:Class="CrystalReportWpfApplication4.Window1" xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml" xmlns:cr="clr-namespace:SAPBusinessObjects.WPF.Viewer;assembly=SAPBusinessObjects.WPF.Viewer" alt="WPF Crystal Report Viewer" Height="600" Width="800" Loaded="Window_Loaded"> ... </Window>- レポートを実行します。レポートが読み込まれると、プロバイダはクエリを実行して現在のデータを取得します。
JD Edwards のデータのチャートを作成する
Chart Expert などのエキスパートとともにDataSet を使用することもできます。
- Crystal Reports Designer を右クリックして「Insert」->「Chart」とクリックします。
- 「Report Header」または「Report Footer」セクションを選択します。Chart Expert が表示されます。
- 「Type」タブでチャートタイプを選択します。この記事では、サイドバイサイドの棒グラフを使用します。
- 「Data」タブでx 軸のカラムと条件を選択します。例えば、DataSet ノードのDocumentNumber カラムを「On Change Of」メニューの下のボックスにドラッグします。
- x 軸のカラムを選択し、「TopN」ボタンと「Order」ボタンをクリックして並べ替えと制限を構成します。
- y 軸のカラムとサマリー操作を選択します。例えば、DataSet ノードのAmount カラムを「Show Values」ボックスにドラッグします。
- レポートを実行します。
Crystal Reports は、JD Edwards API などに対してGROUP BY を実行する代わりに、DataTable にロード済みのデータに対して集計を実行することに注意してください。これは、レポート作成ウィザードにも当てはまります。
別のDataSet を作成し、他のクエリを入力することで、JD Edwards に対して実行されるクエリをより細かく制御できます。ドライバのSQL エンジンの詳細については、ヘルプドキュメントを参照してください。