PowerBuilder から JDBC 経由で JD Edwards のデータ に接続

Jerod Johnson
Jerod Johnson
Director, Technology Evangelism
PowerBuilder で JD Edwards JDBC Driver を使用して JD Edwards のデータ にアクセスする方法を紹介します。



CData JDBC ドライバー for JD Edwards は、 PowerBuilder を含む、JDBC をサポートするあらゆるプラットフォームや開発技術から使用できる標準ベースのコントロールです。 この記事では、PowerBuilder で CData JDBC Driver for JD Edwards を使用する方法について説明します。

ここでは、CData JDBC Driver for JD Edwards を使用してデータを取得する基本的な PowerBuilder アプリケーションの作成方法を説明します。

PowerBuilder から JD Edwards のデータ に接続

以下の手順に従って、Database Painter ツールを使用し、JD Edwards 用の JDBC URL に基づくデータベースプロファイルを作成します。データベースプロファイルを使用して接続プロパティを保存できます。Database Painter では、データをグラフィカルに操作したり、SQL クエリを実行したりできます。

  1. ドライバーの JAR ファイルを PowerBuilder のクラスパスに追加します。CLASSPATH システム環境変数を、インストールディレクトリの lib サブフォルダにあるドライバー JAR へのパスに設定します。

    Note: PowerBuilder Classic を使用している場合は、Tools -> System Options -> Java をクリックしてドライバー JAR へのパスを追加することもできます。

  2. Tools -> Database Painter をクリックします。
  3. JDBC ノードを右クリックし、New Profile をクリックします。
  4. Database Profile Setup ダイアログで、以下の情報を入力します。
    • Profile Name: プロファイルのわかりやすい名前を入力します。
    • Driver Name: ドライバーのクラス名を入力します: cdata.jdbc.jdedwards.JDEdwardsDriver
    • URL: JDBC URL を入力します。

      ドライバーは Application Interface Services(AIS)Server を経由して JD Edwards に接続します。以下の接続プロパティを設定します。

      • URL:AIS Server のベース HTTPS URL(例:https://jde-ais.example.com:8300)。
      • User:JD Edwards のユーザー名。
      • Password:JD Edwards のパスワード。
      • Environment(オプション):使用する JD Edwards の環境(例:本番環境なら PD920、開発環境なら DV920)。指定しない場合は、AIS Server のデフォルト環境が使用されます。
      • Role(オプション):セッションで使用する JD Edwards のロール。指定しない場合は、AIS Server のデフォルトロールが使用されます。
      • DeviceName(オプション):接続元のデバイスまたはアプリケーションの識別子。AIS Server での監査やログ記録に使用されます。
      • Jasserver(オプション):リクエストのルーティング先となる Java Application Server(JAS)インスタンス。クラスタ環境で便利です。

      公開するデータの選択

      JD Edwards ではテーブルとビジネスビューが System Code ごとに整理されており、ドライバーは各 System Code をそれぞれ個別のスキーマとして公開します。利用できるスキーマは、以下のプロパティで制御できます。

      • DataModel:System Code をスキーマとして公開する ERP モジュール(カンマ区切りで複数指定可)。接続先インスタンスのすべての System Code を公開する場合は All を指定します。デフォルトは FinancialManagement です。
      • SystemCodes:DataModel の System Code に加えて公開したい System Code のカンマ区切りリスト(例:42,43)。

      接続時、ドライバーは認証情報を AIS Server に送信してセッショントークンを取得し、キャッシュします。セッションの有効期限が切れる前に、新しいトークンが自動でリクエストされます。

      組み込みの接続文字列デザイナー

      JDBC URL の構築には、JD Edwards JDBC Driver に組み込まれている接続文字列デザイナーが便利です。JAR ファイルをダブルクリックするか、コマンドラインから JAR ファイルを実行します。

      
      java -jar cdata.jdbc.jdedwards.jar
      

      接続プロパティを入力し、接続文字列をクリップボードにコピーします。一般的な JDBC URL は以下のとおりです。

      jdbc:jdedwards:URL=https://your-jde-environment-app.example.com;User=admin;Password=myPassword;
    Database Profile Setup ダイアログで定義された JDBC データソース(画面は Salesforce の例です。)
  5. テーブルを表示および編集するには、テーブルを右クリックして Edit Data -> Grid をクリックします。
Database Painter でのデータベースオブジェクトの操作(画面は Salesforce の例です。)

PowerBuilder コントロールで JD Edwards のデータ を使用

標準の PowerBuilder オブジェクトを使用して JDBC データソースに接続し、クエリを実行できます。以下の例では、JD Edwards のデータ を DataWindow に取得する方法を示します。以下のコードを open メソッドに追加できます。


SQLCA.DBMS = "JDBC"
SQLCA.AutoCommit = False
SQLCA.DBParm = "Driver='cdata.jdbc.jdedwards.JDEdwardsDriver',URL='jdbc:jdedwards:URL=https://your-jde-environment-app.example.com;User=admin;Password=myPassword;";
CONNECT USING SQLCA;
dw_accountspayable.accountledger.SetTransObject(SQLCA);
dw_accountspayable.accountledger.Retrieve();

はじめる準備はできましたか?

JD Edwards Driver の無料トライアルをダウンロードしてお試しください:

 ダウンロード

詳細:

JD Edwards Icon JD Edwards JDBC Driver

JD Edwards 連携のパワフルなJava/J2EE アプリケーションを素早く作成して配布。